[CCNA] RIP

●ディスタンスベクタ型

ルーティングテーブルの情報を交換し、
距離(ホップ数)と方向(ネクストホップ)に基づいて
最適ルートを決定する方式。

C841MにRIPの設定をして、
単体でどういう動きをするのか。

構成はこんな感じ

●RIPの設定

https://www.infraexpert.com/study/distancevector6.html

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.11.0
Router(config-router)#network 192.168.2.0

Router#show ip rip database
192.168.2.0/24    auto-summary
192.168.2.0/24    directly connected, Vlan2
192.168.11.0/24    auto-summary
192.168.11.0/24    directly connected, GigabitEthernet0/4.1

とりあえずリンクしている分だけripに登録。
ここまでの設定で、どんなパケットを出すのかキャプチャ。

192.168.11.0/24側

192.168.2.0/24側

192.168.11.0/24側へは、192.168.2.0の情報を、
192.168.2.0/24側へは、192.168.11.0の情報を
ブロードキャストで飛ばしている。ポートは520。
(後からわかったこと:
 rip の version 1 だとブロードキャスト、
 version 2 だとマルチキャストを使う。)

リンクを元にしたルーティング情報は、
そのリンク以外の方向に飛ばしているみたい。

おそらくこれを受け取った隣のルータが、
メトリックを1つ増やして、
さらに隣のルータに伝えていくと思われる。

一応、もう一個リンクを増やしてみる。

Router#conf t
Router(config)#interface GigabitEthernet 0/4.2
Router(config-subif)#ip address 192.168.4.1 255.255.255.0
Router(config-subif)#encapsulation dot1Q 4
Router(config-subif)#exit
Router(config)#router rip
Router(config-router)#network 192.168.4.0

192.168.11.0/24側

192.168.11.50からは、192.168.2.0と192.168.4.0の情報、
192.168.4.1からは、192.168.2.0と192.168.11.0の情報を
飛ばしている。

では、デフォルトやスタティックルートの
再配布を行った時にはどうなるか。

●デフォルトルートの配布

https://www.infraexpert.com/study/distancevector7.html

リセットしてもう一回

Router#conf t
Router(config)#router rip
Router(config-router)#network 192.168.11.0
Router(config-router)#network 192.168.2.0
Router(config-router)#default-information originate

Router#show run
(中略)
ip route 0.0.0.0 0.0.0.0 192.168.11.1
(中略)
router rip
network 192.168.2.0
network 192.168.11.0
default-information originate

Router#show ip rip database
0.0.0.0/0    auto-summary
0.0.0.0/0    redistributed
    [1] via 0.0.0.0,
192.168.2.0/24    auto-summary
192.168.2.0/24    directly connected, Vlan2
192.168.11.0/24    auto-summary
192.168.11.0/24    directly connected, GigabitEthernet0/4.1

192.168.11.0/24側

192.168.2.0/24側

両方向へデフォルトの通知がされている。

両方向なんだ。ふ~ん・・・

●スタティックルートの再配布

https://beginners-network.com/catalyst_config_rip.html

↑↑の続きから

Router#conf t
Router(config)#ip route 8.8.8.8 255.255.255.255 192.168.11.1
Router(config)#ip route 10.10.10.0 255.255.255.0 192.168.2.10
Router(config)#router rip
Router(config-router)#redistribute static metric 1
Router(config-router)#end

Router#show run
(中略)
ip route 0.0.0.0 0.0.0.0 192.168.11.1
ip route 8.8.8.8 255.255.255.255 192.168.11.1
ip route 10.10.10.0 255.255.255.0 192.168.2.10
(中略)
router rip
redistribute static metric 1
network 192.168.2.0
network 192.168.11.0
default-information originate

Router#show ip rip database
0.0.0.0/0    auto-summary
0.0.0.0/0    redistributed
    [1] via 192.168.11.1, from 0.0.0.0,
8.0.0.0/8    auto-summary
8.8.8.8/32    redistributed
    [1] via 192.168.11.1, from 0.0.0.0,
10.0.0.0/8    auto-summary
10.10.10.0/24    redistributed
    [1] via 192.168.2.10, from 0.0.0.0,
192.168.2.0/24    auto-summary
192.168.2.0/24    directly connected, Vlan2
192.168.11.0/24    auto-summary
192.168.11.0/24    directly connected, GigabitEthernet0/4.1

192.168.11.0/24側

192.168.2.0/24側

スタティックルートの設定で、
転送先が逆方向のものをそれぞれ通知している。
その辺は、リンク情報の考え方と似ている気がする。

それと、staticで設定したよりも、
広いレンジの宛先が通知されている。
自動経路集約機能によるものなので、
詳しくは version 2 で見ていくことにする。

また、スタティック以外にも、
OSPFなどで受け取ったルート情報も再配布できるとのこと。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です